Coming soon: We’re working on a brand new, revamped Community experience. Want to receive updates? Sign up now!

0 votes

We have 2 different Oracle Databases/Connections:

  • ALPHA 
  • BETA

We want to import a table from each database, join them together and append the result in an already existing table in the ALPHA connection.

The table from the connection ALPHA has as schema (in the oracle db)


The table from the connection BETA has as schema (in the oracle db)


The output table ALPHA_OUTPUT that's stored in the connection ALPHA has as schema


To achieve that we create a visual recipe* as follows:


Running this we are getting the following error:

"Table already exists but with an incompatible schema: in act.compute_ALPHA_OUTPUT: Type mismatch for column 1 (REFERENCE_PERIOD) : 'TIMESTAMPLTZ' in dataset, 'TIMESTAMP'(93:DATE) in table"

Things I have already tried:

  • Change the Dataiku Dataset type from date to string (and vice versa)
  • Enable/Disable "Read SQL "timestamp without timezone" as DSS dates"
  • Enable/Disable "Read SQL "date" as DSS dates"

Any suggestions?

* Visual recipe: It's the only option that "works" with multiple connections. "SQL Query recipe" and "SQL Script recipe" both throw an error that multiple connections are not supported.

edited by
Hi, Could you please attach a diagnostic of the affected job? From the job page, click on Actions > Download job diagnosis.
If the resulting file is too large for mail (> 15 MB), you can use a file transfer service like WeTransfer to get it to us, and add the link to this thread.
Hi Alex, Thanks for your quick reply and help.
It does not seem possible to attach files in this forum and I can't use any file transfer service (blocked). As an alternative I can send the logs to you via email. If that's ok with you, please pm me your email.
Sure, you can send them to Alexandre dot Combessie at Dataiku dot com.

1 Answer

0 votes

What you are trying to do isn't possible. When a dataset is used as output of a DSS recipe, it is "managed" by DSS, which will always try to put its own schema. DSS will never create "DATE" fields by itself because DSS does not have a type that corresponds to the Oracle "DATE", i.e. without time of day.

It is thus not possible to have DSS write with a visual recipe into a dataset with a DATE field. Either the DATE field will be dropped or you'll have the schema incompatibility issue you're noting.

Multiple connections are supported in SQL script recipe by going to Advanced and enabling the option to allow multiple connections. It's important to note that multiple connections are actually NOT supported in the visual join recipe: the join will happen in-DSS and the data will get out of Oracle, and back into it.
Hi Clément,

Oracle DATE type includes date and time portion up to milliseconds. We would expect that Dataiku would convert timestamp into Oracle DATE data type by dropping the milliseconds portion and save the data. Any reason why this is not possible to do?

Thanks and regards,
Hi Alex,

Yeah I'm absolutely sure that the input datasets exist as tables.
I assume you are doing the join using an SQL script as Clement advised, with the option to enable multiple connections. Could you post the script you are using please?
Hi Clément,

Have you had a chance to review my feedback? We certainly see it as a defect since the data is taken from an Oracle database and is written back into the same database. Dataiku does the data type conversion resulting in the error and it can be avoided as described in my previous comment.

What do you think?

Best regards,
Hello Denis,
Could you please post the SQL script you are using? Have you tried with the TIMESTAMPTZ type instead of DATE?
Yeah sure, that's the query:

Hi Alex and Clément,

Could you provide an update on this issue please? I.e. when is it going to be fixed by Dataiku?

Kind regards,
Your request has been logged. For now, as advised by Clément, we advise casting the column to the Oracle TIMESTAMPLTZ type. This type will be recognised correctly by both Oracle and DSS.
Hope it helps,
Hi Alex,

Thank you for the update. When should we expect this defect to be fixed?

The suggestion to use TIMESTAMPLTZ data type does not help unfortunately. We have many Oracle databases and datawarehouses with DATE fields and cannot change them all just to workaround the defect in DSS.

Best regards,
Hi Denis,

I'm sorry we didn't really notice your request earlier. Please note that this is a community answers forum, and not really the suitable location to raise formal requests. Followups and tracking is on a best-effort basis here.

For raising requests, we strongly advise you to open support tickets through our support portal. Could you please do so for this request so that we can reply appropriately ?
1,339 questions
1,365 answers
11,916 users

©Dataiku 2012-2018 - Privacy Policy