Coming soon: We’re working on a brand new, revamped Community experience. Want to receive updates? Sign up now!

0 votes


I installed DSS on a mac, OS Yosemite 10.10.15.

While starting DSS, the chrome browser open an empty page with the following text :

"Could not connect to Data Science Studio server

Please check if DSS server is running.

Unknown error
HTTP code: 502, type: Gateway error"

I got no firewall on. DSS have been uninstalled 3 times.


Thanks in advance for your help.





I am getting the same problem. I looked at the log files and see:
Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0
[0.002s][warning][gc] -Xloggc is deprecated. Will use -Xlog:gc:/dev/stderr instead.
Unrecognized VM option 'PrintGCTimeStamps'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

I recently installed the latest JDK and looks like there is some incompatibility re: command line arguments.  Are there scripts that I can fix?

2 Answers

0 votes
It may take some time for DSS to load. Have you tried again after few minutes?
Well I waited a very long time, and tried again and again but it keeps giving me the same message.
OK. So there is a problem somewhere. We would need the logs in order to help you. Could you open a ticket on our support page (link in the right column)? Please attach the logs that you have in this folder: ~/Library/DataScienceStudio/dss_home/run/ (where ~ is the home folder of your user). Thanks.
done, thanks for your help.
0 votes
there is an incompatibility issue with the startup scripts and recent JVMs (I am using 11), regarding logging of garbage collection events.

without knowing all of the details, I fixed the problem by hacking the script "" in


and disable:

#        if addGCLogging and jvm[0] in [ "hotspot", "openjdk" ]:

#            if jvm[1] >= 9:

#                ret += " -Xlog:gc,gc+cpu=info:stderr:t,um,l,ti,tg"

#            elif gc == "g1":

#                # G1 on Java 8 is very very verbose, so don't print GC details

#                ret += " -Xloggc:/dev/stderr -XX:+PrintGCTimeStamps"

#            else:

#                ret += " -Xloggc:/dev/stderr -XX:+PrintGCDetails -XX:+PrintGCTimeStamps"

Nice work :) We confirm that Java 11 is not yet supported. Support is upcoming in the next DSS release.
Is there an update to DSS? I am facing the same issue when I install DSS on Windows using linux sub system - Ubuntu and I am unable to locate with the above content in order to disable them.
1,339 questions
1,365 answers
11,916 users

©Dataiku 2012-2018 - Privacy Policy