0 votes

I'm trying to export data towards Google Sheets. I can retrieve data with the Google Sheets plugin, but now I want to send it.

How can I do this using the Google Sheets plugin?

With kind regards,


1 Answer

0 votes

You should first create a dataset with the plugin Google Sheets? Then, edit/create your recipe and select the dataset as the output.
Great! Thanks for the explanation. But now I get this error:

Failed to write rows : <type 'exceptions.AttributeError'> : 'Worksheet' object has no attribute 'get_addr_int'

What does that mean?
What module should I use to export the data to Google sheets?
This is the error log:

2018-11-14 09:51:13,290 INFO Connecting to parent at port 53541
2018-11-14 09:51:13,291 INFO Connected to parent at port 53541
2018-11-14 09:51:13,397 INFO Processing task: write_rows
2018-11-14 09:51:14,195 INFO Refreshing access_token
Traceback (most recent call last):
  File "/Applications/DataScienceStudio.app/Contents/Resources/kit/python/dataiku/connector/server.py", line 125, in serve
    write_rows(connector, schema, partitioning, partition_id, input)
  File "/Applications/DataScienceStudio.app/Contents/Resources/kit/python/dataiku/connector/server.py", line 63, in write_rows
  File "/var/folders/k8/jbnml6rd43g6_3m16qrz1jxm0000gn/T/tmpgnqPYT/code.py", line 182, in close
  File "/var/folders/k8/jbnml6rd43g6_3m16qrz1jxm0000gn/T/tmpgnqPYT/code.py", line 171, in flush
    cell_list = ws.range( 'A1:%s' % ws.get_addr_int(num_lines, num_columns) )
AttributeError: 'Worksheet' object has no attribute 'get_addr_int'
Did you install the python dependencies in the UI of Dataiku DSS?

I suspect that you don't have the versions of the dependencies expected by the plugin.
What are the dependencies needed for this plugin?
This plugin declares external dependencies  HIDE
gspread (==0.4.0)
oauth2client (>=2.0.0,<2.3.0)
PyOpenSSL (>=0.15.0)
awesome-slugify (>=1.6.5)
To install them, run on the command line:
/DATA_DIR/dss_home/bin/pip install 'gspread==0.4.0' 'oauth2client>=2.0.0,<2.3.0' 'PyOpenSSL>=0.15.0' 'awesome-slugify>=1.6.5'
I'll try to reinstall the plugins.
The plugin should work now.
I'm still getting the same error. I already had all the dependencies installed. Is there anything else I can try to fix this?
There might be a bug with the plugin. I will investigate. You can follow-up here: https://github.com/dataiku/dataiku-contrib/issues/91
Are you getting the same error? Thank you! I'll follow the thread!
1,298 questions
1,326 answers
11,863 users

┬ęDataiku 2012-2018 - Privacy Policy