+1 vote
Yesterday I got started with DSS, had IT install Virtualbox and enable virtualization in the bios - everything worked great.

This morning it's no longer working. I keep getting VT-x error when starting the virtual machine.

We've checked the bios and virtualization is still enabled. Also, Hypver-V is not enabled.

Please help.
edited by
Hi, Could you please share with us the full error? Has there been a specific change on your machine between yesterday and this morning? Yesterday did you manage to connect to Dataiku DSS and use it?
Hi thanks for responding.

The full error is

VT-x is not available (VERR_VMX_NO_VMX).
Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

No change to the machine - it's been locked in my desk drawer.

Yes on the first day I was able to connect to Dataiku DSS and import some data, run models etc. It was working fine. But no longer.

2 Answers

0 votes
Best answer
For future users who encounter this problem:

There is no solution.

The issue is caused by Windows Device Guard blocking virtualbox. So unless you can convince IT to disable Device Guard, this effectively shuts down this method of trialling Dataiku.
selected by
0 votes

Hardware virtualization is needed for Dataiku DSS to work in a virtual machine. You should find some troubleshooting help on: https://doc.dataiku.com/dss/latest/installation/other/vm.html#hardware-virtualization


Alex, as you can see from my original post - Hardware virtualization is enabled.
This issue is linked to VirtualBox and your operating system. You should find help in the links referenced in our documentation.
Could you be more specific?  I'm using Windows 10 64-bit with 16gb ram.

My laptop was with IT for an hour yesterday and they couldn't solve the problem.
Has IT uninstalled hyper V and then restarted your computer? The link referenced in our documentation (http://druss.co/2015/06/fix-vt-x-is-not-available-verr_vmx_no_vmx-in-virtualbox/) corresponds to the same error you posted.
Hyper-V was never enabled, we looked and it is un-ticked.

We will try enabling it and then disabling it again and see if that helps.
We've now tried this and it hasn't worked.

We either get the VT-x error:

VT-x is not available (VERR_VMX_NO_VMX).

OR, if we reduce the RAM available to the VM, we get the following Hyper-V error:

Raw-mode is unavailable courtesy of Hyper-V. (VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT).

But to be clear:
Virtualization is ON
Hyper-V is OFF

So we shouldn't get either of these errors.
Did you disable or uninstall HyperV? It specifically needs to be uninstalled, disabling may not be enough. Then you need to restart your computer.
We've followed the instructions in the documentation (windows features > untick Hyper-V>restart PC).

One article calls it 'uninstalling' and another calls it 'disabling' but the instructions are identical.
1,296 questions
1,325 answers
11,862 users

┬ęDataiku 2012-2018 - Privacy Policy