0 votes

Hello, I have been trying to install the code environments on my mac and I can only create the python2.7 environment, when I tell DSS to use the managed python3.6 says it is not in path. when I tell it to use conda says "conda" no such file or directory, and when I give it custom I give my anaconda directory where my python 3 is, but it gets the error "pip._vendor.requests.packages.urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host='pypi.python.org', port=443): Read timed out.".

Any help will be greatly appreciated

Another problem I have gotten since this was posted, I tried to use R that I integrated using the command "install-R-integration" but I get that the package Dataiku does not exist:

P.S. image answer from comment:

---- comment ----

(image 1)

(image 2)

(image 3)

(image 4)

(image 5)

(image 6)

edited by
Hello, what is the result of the `conda --version` command in your mac terminal?
I get conda 4.4.4
I do not reproduce this problem on my mac with conda 4.4.4. How did you install conda? What is the result of the command `which python3`?
For your other issue regarding R, have you restarted DSS after running the install-R-integration script? Which R code environment are you using for the notebook kernel?
I get '/Users/larispardo/anaconda/bin/python3'  which I tried to use before at 'custom'. I will check it again.
For the R I restarted dataiku again just on case and it still appears, and I cannot create the new environment since it appears:
'Environment creation failed
the R I have now I added it using the shell command:
'./bin/dssadmin install-R-integration'
Could you share screenshots and full error messages when you try to create a managed conda environment in DSS? Same for R environment. This information will be helpful for us to be able to help you.
Hello, today I tried again in R and got an error (image 1 and 2), but latter I stoped DSS and ran install-R-Integration and when starting again I was able to run my codes (image 3 and 4). I guess it was some kind of unique bug, since the kernel never appeared as death, but did not have Dataiku package before.
For the python error I get now "conda environment not found" (image 5) even though it is the name of the environment I get when runing "conda-env list" (image 6) in the terminal, I am not sure why is this happening.
Hello, great to hear that you got R up and Running. For conda, how are you creating the environment? Is is it in managed mode? Are you running Anaconda 3? I got it working fine on my Mac with this setting: https://imgur.com/a/io9Ke
- I am creating the environment as your image's and also putting "Named external Conda environment"
-I believe is anaconda 1.6.3 from "anaconda-client-1.6.3-py36_0.json"
I have done it in the managed mode, with the managed it tried to download it and then I get
"Environment creation failed
Process execution failed (conda) (return code 1)"
with an error that is not marked
"The following NEW packages will be INSTALLED:
    ca-certificates: 2017.08.26-ha1e5d58_0
    certifi:         2018.1.18-py36_0     
pip 9.0.1: #########7 |  98%
pip 9.0.1: ########## | 100%
CondaError: Downloaded bytes did not match Content-Length
  url: https://repo.continuum.io/pkgs/main/osx-64/python-3.6.4-hc167b69_1.tar.bz2
  target_path: /Users/larispardo/anaconda/pkgs/python-3.6.4-hc167b69_1.tar.bz2
  Content-Length: 15991177
  downloaded bytes: 8878958
    libcxx:          4.0.1-h579ed51_0     
    libcxxabi:       4.0.1-hebd6815_0     
    libedit:         3.1-hb4e282d_0       
    libffi:          3.2.1-h475c297_4     
    ncurses:         6.0-hd04f020_2       
    openssl:         1.0.2n-hdbc3d79_0    
    pip:             9.0.1-py36_5         
    python:          3.6.4-hc167b69_1     
    readline:        7.0-hc1231fa_4       
    setuptools:      38.5.1-py36_0        
    sqlite:          3.22.0-h3efe00b_0    
    tk:              8.6.7-h35a86e2_3     
    wheel:           0.30.0-py36h5eb2c71_1
    xz:              5.2.3-h0278029_2     
    zlib:            1.2.11-hf3cbc9b_2    
Downloading and Extracting Packages
that is what I get. not sure if it is my work's internet, I will check it again at home to see.
The managed conda env should work if you have unrestricted Internet access. I will investigate the case of a named external conda env, which works differently as the managed one.
of course, I will also check with the unrestricted internet, the more I dig in I believe is something of a unique "bug" (if you want to call it someway) that has to do with my personal computer more than with all others. If I understand what is happening I will also post it here. Thank you very much for your help Alexandre.

1 Answer

0 votes

I confirm that it works on my mac (High Sierra 10.13.3) as an external conda environment created through Anaconda Navigator 1.7 and Anaconda3 4.4.4. I tested it on DSS 4.1.5. It also works as a managed conda environment, which is the recommended way to work with conda in DSS, provided you have unrestricted Internet access.

Could you try and match the versions listed above and see if it works? Let us know if you find the root cause of the issue by posting any additional error messages and commands.


Okey, I had an finding while working with this issue today. I notices I had DSS 4.1.3 and upgrade it. When I entered I had the same issue I had when I first posted this question, so I quit and opened it again and the same thing "cannot run "conda"" (more info in the link with the images) so I stopped DSS from the terminal and started again, and only then I was able to create the environment using conda. I am not sure why this happened, but I really appreciate your help.
Indeed, we added support for conda 4.4 in the version 4.1.4 of DSS. See our official release notes: https://doc.dataiku.com/dss/latest/release_notes/4.1.html#id2. Hence upgrading DSS to the latest version is the solution.
1,322 questions
1,341 answers
11,889 users

©Dataiku 2012-2018 - Privacy Policy