Coming soon: We’re working on a brand new, revamped Community experience. Want to receive updates? Sign up now!

0 votes


I can't use Bokeh or Shiny webapp when DSS is running in Docker, the backend log shows the following, and hangs until it fails:

[FT-StartWaitThread-gzPzm1u5-234] [INFO] [dku.webapps.bokeh]  - [ct: 2750] Get http://localhost:50890
[FT-StartWaitThread-gzPzm1u5-234] [INFO] [dku.webapps.backends]  - [ct: 2755] Failed to contact webapp backend, wait...

I created a macvlan network interface and exposed all ports but it still doesn't work. Is there a specific Docker configuration to make it work?

No problem when running DSS natively on a Linux host, but I need Docker in this environment. 

Thanks in advance


Could you share with us your docker run script, including for network and port configuration?
Thanks for your answer, I initially followed the instructions there, but the webapps didn't worked:

docker run --name=dss -p 10000:10000  -v /home/user/Development/docker/dataiku_data/:/home/dataiku/dss -d dataiku/dss


Then I tried a macvlan interface so that the container has its own IP address, but still doesn't works:
docker network create -d macvlan --subnet --gateway -o parent=eno1 docker-macvlan-net

docker run --network docker-macvlan-net --name=dss -p 1000-65000:1000-65000 -v  /home/user/Development/docker/dataiku_data/:/home/user/dss -d dataiku/dss
Thanks for sharing these details. There does not seem to be a networking issue in your setup. It could be that bokeh hangs at initialization. Could you try restarting the backend of the webapp and see if the problem happens again? Are you using one of our bokeh example template or your own code?

1 Answer

+1 vote
Best answer
It works now, there's no specific network config to do actually. I just pulled the latest Docker image, did the DSS upgrade (, and that worked afterward!

Thanks for your help
selected by
Ok great! Thanks for letting us know. Have a good day!
1,339 questions
1,365 answers
11,916 users

©Dataiku 2012-2018 - Privacy Policy