0 votes

Hi I have started everything as instructed on https://www.dataiku.com/dss/trynow/linux/  and when tried accessing myserverip:11000 or myserver:11001 then, it raised error


Problem accessing /. Reason:

    Not Found

When i checked DATA_DIR/bin/dss status
backend                          RUNNING   pid 5142, uptime 0:15:15
hproxy                           RUNNING   pid 5141, uptime 0:15:15
ipython                          RUNNING   pid 5139, uptime 0:15:15
nginx                            FATAL     Exited too quickly (process log may have details)


Is this nginx causing issue? Then How i can install this.

I am new to linux system, please suggest a way to fix. Thanks in Advance.


1 Answer

+1 vote

Try looking at the "run/nginx.log" file (from the DSS data directory), it will probably contain more information about why nginx failed to start.
Hi, Thanks for such a fast response.
it's showing nginx binary not found.
If i am not wrong, it means i don't have a nginx installation on my server.
Though I have apache. Is there any way i can use apache in place of nginx(by changing any config).
Or to run dss, nginx is mandatory.
Then can i run nginx and apache together?(Yeah i have to google if it comes to this point!!!)
You need to install nginx, DSS cannot use Apache. What is weird is that installation of DSS should have installed nginx automatically. Try running sudo /PATH/TO/INSTALL/DIR/scripts/install/install-deps.sh (it will install nginx and set it automatically so as not to conflict with your Apache)
Hi, I have install nginx separately and started in a different port that apache acquired 80. It works fine now. Thanks for all the support.
1,299 questions
1,327 answers
11,865 users

©Dataiku 2012-2018 - Privacy Policy