0 votes

Hello guys,

I am on a Ubuntu Server EC2 instance on Amazon and when I launch the installer.sh I am getting the following exception:

[2017/06/05-14:17:34.870] [main] [INFO] [dku.logging]  - Loading logging settings
[2017/06/05-14:17:34.874] [main] [INFO] [dku.logging]  - Configuring additional logging settings from /home/ubuntu/Downloads/dataiku-dss-4.0.4/resources/logging/dku-log4j.properties
[2017/06/05-14:17:48.377] [main] [WARN] [org.springframework.context.annotation.AnnotationConfigApplicationContext]  - Exception encountered during context initialization - cancelling refresh attempt
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'h2BasedTimestampsDAO': Invocation of init method failed; nested exception is org.h2.jdbc.JdbcSQLException: IO Exception: "java.net.UnknownHostException: ip-*-*-*-164: ip-*-*-*-164: Name or service not known" [90028-176]
        at org.springframework.beans.factory.annotation.InitDestroyAnnotationBeanPostProcessor.postProcessBeforeInitialization(InitDestroyAnnotationBeanPostProcessor.java:133)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyBeanPostProcessorsBeforeInitialization(AbstractAutowireCapableBeanFactory.java:396)

I have deliberately obfuscated the hostname: ip-*-*-*-164.

I am wondering if actually the installer should attempt instead to connect to localhost or ?


This is not the AMI AWS instance, but just a plain wget and install setup.

Hi, could you attach the complete backend.log, not just a snippet ? (note that EC2 hostnames are internal IPs, not public one, so they don't leak information)

Hello sure,

the log is too long so I had to put it here.


It looks like the network configuration of the machine has some issues and that the machine can't resolve its own name.

What do the following commands give:

* hostname -f
* cat /etc/hosts
* getent hosts `hostname -f`
Yes that seems to be the likely issue in fact:
1) hostname -f returns hostname: Name or service not known
2) cat /etc/hosts: localhost

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

3) getent hosts `hostname -f`:

hostname: Name or service not known       localhost       ip6-localhost ip6-loopback
I think I have solved the problem by adding: ip-*-*-*-164 to the /etc/hosts.
Thank you for pointing that out!

1 Answer

0 votes
Best answer
Issue solved in comment thread.
1,296 questions
1,325 answers
11,862 users

©Dataiku 2012-2018 - Privacy Policy