Coming soon: We’re working on a brand new, revamped Community experience. Want to receive updates? Sign up now!

+2 votes
Hey !

I followed all the steps of this tutoriel:

But when i open the URL in my browser (Firefox or Chrome): (i check it's the same as in my VM, Data Science Studio interface:

I got this message: "invalid request"

I checked with some firefox tools and it says that the HTML document encoding caracter hasn't been declared.


If you got some answer for my problem i would be very happy =) !
edited by

1 Answer

+2 votes
The most common issues related to this:

- The VM just takes a long time to start, did you wait long enough?

- Somehow the studio did not boot correctly, you can connect to the VM, and use "dss/bin/dss status" to see if everything is running. If not, use "dss/bin/dss restart".
Thank you for your answer but unfortunately it's not the good one for my problem.

- Yes I wait until my VR get started (I can see the msg in it: Welcome to Dataiku ...)

-I did dss/bin/dss status in my VR, the was the answer:

backend     RUNNING pid 2808, uptime 0:07:02
ipython       RUNNING pid 2806, uptime 0:07:02
nginx           RUNNING pid 2807, uptime 0:07:02

So everything should be ok no ?

I also restarted the dss to see what happend but i always got the same message on my Browser page ( invalid request )

ps: When i do arp -a on the cmd of my computer it show me that the VM is connected
Indeed everything should be working.
Next thing you can try is within the VM: curl localhost:10000
If you get some html text, it means the studio is running and responding (I expect this to be the case in your situation).

So now we know that it is a network issue, meaning that your machine (through a browser) cannot talk to the VM. You will have to check firewall settings...

This issue is not common at all but we suspect having seen at least another occurence. Any findings that you make would be of great value for us in understanding the problem.
Thank you again for your quick answer !

I took the easy way and i downloaded the app on my mac. I know i'm coward hahaha !
Thank you for your time cperdigou.
I run a windows 10 and successfully installed Virtualbox and loaded DSS.
Now I'm receiving this "invalid request" from chrome (also ie).

I did the described above and VM  return the corrected listed status, also returned HTML. The only thing that I don't know how to check is the "arp -a"command. When done the is not on the list.

 I need some guidance on what could be the next steps to make it work.
You could try to use the developer tools of your browser and reload the page, see if there is any red error message and send it to us here.

Note that IE is not supported, you can use DSS with Chrome or Firefox only.

In chrome:
- Open the address of dataiku DSS:
- Press Ctrl + Shift + J
- Reload the page, and look at any error message here
- Go to the Network tab and reload the page again

You can post here your error messages if you find any!

I have the same problem. I follow the guideline and I have this error message when I test your last tips : GET net::ERR_CONNECTION_REFUSED

I also did a netstat command and port 10000 doesn't appear so I add it but i can not still access to the gui.

Have you got other idea ?

PS : I am using virtual box on windows 10 and chrome
i face the same problem since last week.
Everything worked welle before but i now get "invalid request" when loading the address on

The status are OK and the VM also returned the HTML.

With the developer tools, it seems there are two errors i don't know to deal with:

Failed to load resource: the server responded :10000/favicon.ico Failed to load resource: the server responded with a status of 400 (ERROR)
Failed to load resource: the server responded with a  status of 400 (ERROR)

Can you help me with that?

1,337 questions
1,362 answers
11,912 users

©Dataiku 2012-2018 - Privacy Policy