0 votes


I am trying to use the Google sheet plugin.

I have installed all the dependencies required  in the DataScienceStudio/dss_home/bin folder

  • gspread (>=0.2.5)
  • oauth2client (>=1.5.0)
  • PyOpenSSL (>=0.15.0)
  • awesome-slugify (>=1.6.5)

but I still have the same error:

Test failed: cannot import name SignedJwtAssertionCredentials

I googled the error and I install few more package:

$ pip install pycrypto

$ pip install pyopenssl
$ pip install httplib2
$ pip install oauth2client
$ pip install ssl


But it is still not working.

I would really much appreciate you help .



----conf info---

Mac os El Capitan 10.11.5


Hi, just to make sure, did you use DATA_DIR/bin/pip instead of the system's pip?
(See http://www.dataiku.com/learn/guide/code/python/install-python-packages.html for details).
Yes, I was in  the DATA_DIR/bin/pip.

cd /Users/adrien/Library/DataScienceStudio/dss_home
./bin/pip install --upgrade pip
./bin/pip install --upgrade gspread
./bin/pip install --upgrade awesome-slugify
./bin/pip install --upgrade PyOpenSSL
./bin/pip install --upgrade awesome-slugify
./bin/pip install --upgrade oauth2client==1.5.2
./bin/pip install --upgrade cryptography
./bin/pip install --upgrade gspread
./bin/pip install --upgrade oauth2client
./bin/pip install --upgrade PyOpenSSL
./bin/pip install --upgrade pycrypto
./bin/pip install --upgrade pyopenssl
./bin/pip install --upgrade httplib2
./bin/pip install --upgrade ssl

1 Answer

+1 vote
Best answer


Thanks for reporting this.

In the list you provided, we can see that oauth2client appears twice.

./bin/pip install --upgrade oauth2client==1.5.2
./bin/pip install --upgrade oauth2client

The second one is probably with the newest version, and there is known issue when oauth2client >= 2.0.0.

What I suggest:

  • Delete both (./bin/pip uninstall oauth2client oauth2client==1.5.2) and install again the 1.5.2 version (./bin/pip install oauth2client==1.5.2)
  • Or, there is a beta of a new version of the plugin available that works with oauth2client >= 2.0.0. You can download the zip here. Make sure you install again the dependencies in DSS administration after installation.

Let us know if that helps.


selected by
Thank you so much, Jermy!
It's working well now.
And also thank you for the new version, I was looking for how to write in a google sheet.
You're welcome! Let me know if you have any issue with this beta.
1,218 questions
1,249 answers
11,782 users

┬ęDataiku 2012-2018 - Privacy Policy