0 votes
Ubuntu 18.04.3 64bit

trying to use forecast plugin

Got DKURBIN error
-> tried:
./bin/dssadmin install-R-integration

not error while installation, as far as i can see.

got RJSONIO lib not found error

Can not see the env managed by dss in the code env, therefore i can not add the missing package.

What can i do?

by
I deinstalled the environment and created a new one for the plug in.
Now all forecast steps ( clean, model,compute) run without errors.

But results are wrong, because the model step does not recognize the date format right.
Only the "Date 00:00:00" all other hours of the day are erased from the table. Therefore the forecast is wrong.
This is like the last post i did here. The VM is totally new, dataiku is fresh installed, the flow and data is now from a college where it is working. So the last difference i know of is Ubuntu 18.04.3
Hi, Would you be able to send a sample of the data you are using? I will try to reproduce.

1 Answer

0 votes

Hi,

I was able to trace down the issue to the way R handles timezone default. It can vary depending on the R setup and your OS.

A short-term simple solution is to set the default time zone variable in R, as explained in threads such as https://stackoverflow.com/questions/6374874/how-to-change-the-default-time-zone-in-r

In the next release of the Forecast plugin, we will change the behaviour to use "UTC" as an explicit default instead of looking for the default timezone variable in your R environment.

Hope it helps,

Alex

by
So i guess i have to create a manually managed R env where i can specify this?
My first attempt was to create an R node in the flow that that only changes this env variable, and doesnt do anything more. In my flow this works but the forecast plugin is still running into an error. In the flow of my college already the default R node as created by DSS only with the line for readin in the Dataframe and giving it back is running into an error when executed....

it all breaks down to the R and Python Env´s, when using the Virtualbox ISO you provided, everything works fine.
When I install everything by myself following your "normal" Windows WLS or DSS Linux guides.  Using your automated plug in and library downloads. Following the R integration steps. I will run into problems, if i do more than the dataiku tutorials.
To permanently set the timezone parameter for all R environments, I suggest you edit the Renviron.site file. This answer indicates how to do so: https://stackoverflow.com/a/30881689.
If you run into further problems, please post the logs of the errors.
Hey Alex, we changed the environment variable TZ="UTC". As explained in the links.
Sadly this does not resolve the issue.

to find the error I started new from scratch, with an ansibile script that already does the R-integration and sets the Timezone.
This time I used the tryed to keep the miliseconds and parsed the date with
yyyy-MM-dd HH:mm:ss+SSS

2019-03-04 00:01:05+01 -> 2019-03-04T00:01:05.010Z

This leads to the error:

Error in R process: simpleError : Resampled data is 3 times longer than input data. Please check time granularity setting.

In the plug in i chose by hour, average and interpolate.
By the way, in the appstore the explanation link of the forecast plugin leads to a 404 error.
thanks for your help
Hi, Would you be able to send me a sample of your data? You can contact me at alex [dot] combessie [at] dataiku [dot] com. Thank you?
Hi, Please note that we have just release an update to the plugin (0.3.1) which solves the timezone not set issue. Could you give it a try? If you still get an error, please followup with a sample of your data and the error logs. Thanks!
1,322 questions
1,342 answers
1,543 comments
11,891 users

©Dataiku 2012-2018 - Privacy Policy