0 votes
I have installed dataiku, everything seems to work fine except that when connecting to the UI, the following message appears : "Oops: an unexpected error occured
If this happens again, please use Feedback to tell us more about what you were doing.

NullPointerException
HTTP code: 500, type: java.lang.NullPointerException".

Nginx logs show those errors : " nginx: [alert] could not open error log file: open() "/var/log/nginx/error.log" failed (13: Permission denied)
2016/04/18 05:13:50 [error] 12211#0: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 10.0.2.15, server: , request: "GET /dip/api/shaker/get_processors_library/ HTTP/1.1", upstream: "http://127.0.0.1:65001/dip/api/shaker/get_processors_library/", host: "quickstart.cloudera:65000", referrer: "http://quickstart.cloudera:65000/"
2016/04/18 05:13:50 [error] 12211#0: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 10.0.2.15, server: , request: "GET /dip/api/shaker/list-custom-formulas-functions HTTP/1.1", upstream: "http://127.0.0.1:65001/dip/api/shaker/list-custom-formulas-functions", host: "quickstart.cloudera:65000", referrer: "http://quickstart.cloudera:65000/"
2016/04/18 05:13:50 [error] 12211#0: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 10.0.2.15, server: , request: "GET /dip/api/shaker/get-expression-syntax HTTP/1.1", upstream: "http://127.0.0.1:65001/dip/api/shaker/get-expression-syntax", host: "quickstart.cloudera:65000", referrer: "http://quickstart.cloudera:65000/"
2016/04/18 05:13:50 [error] 12211#0: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 10.0.2.15, server: , request: "GET /dip/api/datasets/get-types/ HTTP/1.1", upstream: "http://127.0.0.1:65001/dip/api/datasets/get-types/", host: "quickstart.cloudera:65000", referrer: "http://quickstart.cloudera:65000/"
2016/04/18 05:13:50 [error] 12211#0: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 10.0.2.15, server: , request: "GET /dip/api/datasets/get-common-charsets/ HTTP/1.1", upstream: "http://127.0.0.1:65001/dip/api/datasets/get-common-charsets/", host: "quickstart.cloudera:65000", referrer: "http://quickstart.cloudera:65000/"
2016/04/18 05:13:50 [error] 12211#0: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 10.0.2.15, server: , request: "GET /dip/api/datasets/get-format-types/ HTTP/1.1", upstream: "http://127.0.0.1:65001/dip/api/datasets/get-format-types/", host: "quickstart.cloudera:65000", referrer: "http://quickstart.cloudera:65000/"
2016/04/18 05:13:50 [error] 12211#0: *2 connect() failed (111: Connection refused) while connecting to upstream, client: 10.0.2.15, server: , request: "GET /dip/api/get-configuration HTTP/1.1", upstream: "http://127.0.0.1:65001/dip/api/get-configuration", host: "quickstart.cloudera:65000", referrer: "http://quickstart.cloudera:65000/"
nginx: [alert] could not open error log file: open() "/var/log/nginx/error.log" failed (13: Permission denied)
nginx: [alert] could not open error log file: open() "/var/log/nginx/error.log" failed (13: Permission denied)"

What should I do ?
by
To give you more information. I've set up a Quickstart VM Cloudera 5.4.2 and installed dataiku 2.3.2 on it. I followed the manual to set up the install using the default user of the Cloudera VM : Cloudera. However, it seems that despite my services running correctly, I cannot connect to the UI itself using my web browser (despite desabling proxies and using the lastest version of firefox).

1 Answer

0 votes
You might have a permission error.

You should install and run DSS with the same unix user. More info in the doumenation: http://doc.dataiku.com/dss/latest/installation/new_instance.html

I hope that helps,

Jeremy
by
Thank you Jeremy. I'll recheck this tomorrow but if I remember correctly the user for the installation and the running process were the same. I'll give you confirmation when I can.

Kind regards,

Fabien
Okay, I just figured out the problem. It was a licence issue. I had copied and pasted the licence code into a text document that would serve me as the licence entry at the moment of installation. However, Dataiku wouldn't be able to parse it correctly and wouldn't be able to send the right requests to the server to get the corresponding configuration for the enterprise version of Dataiku.
1,279 questions
1,306 answers
1,487 comments
11,835 users

┬ęDataiku 2012-2018 - Privacy Policy