0 votes
Hi,

After create my connection with sucess to my postgresql database.

I've the following error when I import my table in my project :

An invalid argument has been encountered : Invalid number of columns in query (2, expected 0) SELECT * FROM "public"."ape_ref" LIMIT 10000. Please check dataset schema

Could you explain me the reason of this error ?
by
reopened by

2 Answers

0 votes
Best answer

If you create a new dataset (postgresql in my case) with just filling fields and click on CREATE button

The error "Invalid number of columns in query" appear

The reason of the problem is your dataiku schema is empty.


To correct this one, click on CHECK DATA button and RELOAD SCHEMA USING DETECTED DATA button

Now, you can use your dataset after you push CREATE button :)

by
selected by
0 votes

Hi,

Can you try the following: go to your table, then Settings -> Schema -> Reload schema from table

Cheers,

Du Phan

by
Thanks it's works now
1,258 questions
1,292 answers
1,467 comments
11,809 users

┬ęDataiku 2012-2018 - Privacy Policy