0 votes
Hello!

I'am trying to install Google Sheets connector, but when I click on "TEST&GET SCHEMA", the system return the error: "Test failed: Failed to initialize kernel : <type 'exceptions.ImportError'> : No module named slugify".

And before that, installation process resulted in error (but no debug message).

I alredy update pip and slugify packeges, but no success.

Can you help me?
by
Hi Heitor, can you confirm with version of plugin you have?
Hi!

The default version in Administration > Plugins > Store == 1.0.0

Regards,

1 Answer

0 votes

Hi,

Since version 1.0.0, the plugin works with a dedicated code environment.

You need to make sure that:

1. The dedicated code env is created.

In DSS 5.1, it looks like this:

2. The code env has been set-up (dependencies are installed).

You can check and rebuild in Administration > Code Envs > plugin_googlesheets_managed

 

I hope it will solve your issue.

by
Hi!

I alredy solved the problem.

tks,
i am having the same error. I have the latest versions of the plugin in and DSS.

When i try to do this step:

2. The code env has been set-up (dependencies are installed).

You can check and rebuild in Administration > Code Envs > plugin_googlesheets_managed

I get the following error:


Collecting urllib3<1.25,>=1.21.1 (from requests==2.21.0->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 5))
  Using cached https://files.pythonhosted.org/packages/01/11/525b02e4acc0c747de8b6ccdab376331597c569c42ea66ab0a1dbd36eca2/urllib3-1.24.3-py2.py3-none-any.whl
Collecting pyasn1>=0.1.7 (from oauth2client==4.1.3->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 7))
  Using cached https://files.pythonhosted.org/packages/7b/7c/c9386b82a25115cccf1903441bba3cbadcfae7b678a20167347fa8ded34c/pyasn1-0.4.5-py2.py3-none-any.whl
Collecting pyasn1-modules>=0.0.5 (from oauth2client==4.1.3->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 7))
  Using cached https://files.pythonhosted.org/packages/91/f0/b03e00ce9fddf4827c42df1c3ce10c74eadebfb706231e8d6d1c356a4062/pyasn1_modules-0.2.5-py2.py3-none-any.whl
Collecting httplib2>=0.9.1 (from oauth2client==4.1.3->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 7))
Collecting rsa>=3.1.4 (from oauth2client==4.1.3->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 7))
  Using cached https://files.pythonhosted.org/packages/02/e5/38518af393f7c214357079ce67a317307936896e961e35450b70fad2a9cf/rsa-4.0-py2.py3-none-any.whl
Collecting regex (from awesome-slugify==1.6.5->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/77/3f/cf89d346dd73f0f5eb118ff3ec0d9f3760f1ea85e2ede9eecac9648e0172/regex-2019.05.25.tar.gz
Collecting Unidecode<0.05,>=0.04.14 (from awesome-slugify==1.6.5->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 8))
  Using cached https://files.pythonhosted.org/packages/01/a1/9d7f3138ee3d79a1ab865a2cb38200ca778d85121db19fe264c76c981184/Unidecode-0.04.21-py2.py3-none-any.whl
Collecting enum34; python_version < "3" (from cryptography>=2.3->pyOpenSSL->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 4))
  Using cached https://files.pythonhosted.org/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl
Collecting cffi!=1.11.3,>=1.8 (from cryptography>=2.3->pyOpenSSL->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 4))
  Using cached https://files.pythonhosted.org/packages/16/f6/46a3dece43541b2cbf3776ec2299e370a2408d9380958401cacb6d101853/cffi-1.12.3-cp27-cp27m-macosx_10_6_intel.whl
Collecting asn1crypto>=0.21.0 (from cryptography>=2.3->pyOpenSSL->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 4))
  Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting ipaddress; python_version < "3" (from cryptography>=2.3->pyOpenSSL->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 4))
  Using cached https://files.pythonhosted.org/packages/fc/d0/7fc3a811e011d4b388be48a0e381db8d990042df54aa4ef4599a31d39853/ipaddress-1.0.22-py2.py3-none-any.whl
Collecting pycparser (from cffi!=1.11.3,>=1.8->cryptography>=2.3->pyOpenSSL->-r /Users/jay/Library/DataScienceStudio/dss_home/tmp/pip-requirements-install/req1760457259683285447.txt (line 4))
Building wheels for collected packages: regex
  Building wheel for regex (setup.py): started
  ERROR: Complete output from command /Users/jay/Library/DataScienceStudio/dss_home/code-envs/python/plugin_googlesheets_managed_1/bin/python -u -c 'import setuptools, tokenize;__file__='"'"'/private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-install-e9IK9C/regex/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-wheel-PBdLjO --python-tag cp27:
  ERROR: BASE_DIR is /private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-install-e9IK9C/regex
  /Users/jay/Library/DataScienceStudio/dss_home/code-envs/python/plugin_googlesheets_managed_1/lib/python2.7/site-packages/setuptools/dist.py:472: UserWarning: Normalizing '2019.05.25' to '2019.5.25'
    normalized_version,
  running bdist_wheel
  running build
  running build_py
  creating build
  creating build/lib.macosx-10.14-intel-2.7
  creating build/lib.macosx-10.14-intel-2.7/regex
  copying regex_2/regex/__init__.py -> build/lib.macosx-10.14-intel-2.7/regex
  copying regex_2/regex/regex.py -> build/lib.macosx-10.14-intel-2.7/regex
  copying regex_2/regex/_regex_core.py -> build/lib.macosx-10.14-intel-2.7/regex
  creating build/lib.macosx-10.14-intel-2.7/regex/test
  copying regex_2/regex/test/__init__.py -> build/lib.macosx-10.14-intel-2.7/regex/test
  copying regex_2/regex/test/test_regex.py -> build/lib.macosx-10.14-intel-2.7/regex/test
  running build_ext
  building 'regex._regex' extension
  creating build/temp.macosx-10.14-intel-2.7
  creating build/temp.macosx-10.14-intel-2.7/regex_2
  Building wheel for regex (setup.py): finished with status 'error'
  cc -fno-strict-aliasing -fno-common -dynamic -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -pipe -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c regex_2/_regex.c -o build/temp.macosx-10.14-intel-2.7/regex_2/_regex.o
  Running setup.py clean for regex
  xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
  error: command 'cc' failed with exit status 1
  ----------------------------------------
  ERROR: Failed building wheel for regex
Failed to build regex
Installing collected packages: numpy, six, python-dateutil, pytz, pandas, enum34, pycparser, cffi, asn1crypto, ipaddress, cryptography, pyOpenSSL, certifi, chardet, idna, urllib3, requests, gspread, pyasn1, pyasn1-modules, httplib2, rsa, oauth2client, regex, Unidecode, awesome-slugify
    ERROR: Complete output from command /Users/jay/Library/DataScienceStudio/dss_home/code-envs/python/plugin_googlesheets_managed_1/bin/python -u -c 'import setuptools, tokenize;__file__='"'"'/private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-install-e9IK9C/regex/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-record-dzkmEx/install-record.txt --single-version-externally-managed --compile --install-headers /Users/jay/Library/DataScienceStudio/dss_home/code-envs/python/plugin_googlesheets_managed_1/include/site/python2.7/regex:
    ERROR: BASE_DIR is /private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-install-e9IK9C/regex
    /Users/jay/Library/DataScienceStudio/dss_home/code-envs/python/plugin_googlesheets_managed_1/lib/python2.7/site-packages/setuptools/dist.py:472: UserWarning: Normalizing '2019.05.25' to '2019.5.25'
      normalized_version,
    running install
    running build
    running build_py
    creating build
    creating build/lib.macosx-10.14-intel-2.7
    creating build/lib.macosx-10.14-intel-2.7/regex
    copying regex_2/regex/__init__.py -> build/lib.macosx-10.14-intel-2.7/regex
    copying regex_2/regex/regex.py -> build/lib.macosx-10.14-intel-2.7/regex
    copying regex_2/regex/_regex_core.py -> build/lib.macosx-10.14-intel-2.7/regex
    creating build/lib.macosx-10.14-intel-2.7/regex/test
    copying regex_2/regex/test/__init__.py -> build/lib.macosx-10.14-intel-2.7/regex/test
    copying regex_2/regex/test/test_regex.py -> build/lib.macosx-10.14-intel-2.7/regex/test
    running build_ext
    building 'regex._regex' extension
    creating build/temp.macosx-10.14-intel-2.7
    creating build/temp.macosx-10.14-intel-2.7/regex_2
    cc -fno-strict-aliasing -fno-common -dynamic -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -pipe -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c regex_2/_regex.c -o build/temp.macosx-10.14-intel-2.7/regex_2/_regex.o
    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
    error: command 'cc' failed with exit status 1
    ----------------------------------------
  Running setup.py install for regex: started
    Running setup.py install for regex: finished with status 'error'
ERROR: Command "/Users/jay/Library/DataScienceStudio/dss_home/code-envs/python/plugin_googlesheets_managed_1/bin/python -u -c 'import setuptools, tokenize;__file__='"'"'/private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-install-e9IK9C/regex/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-record-dzkmEx/install-record.txt --single-version-externally-managed --compile --install-headers /Users/jay/Library/DataScienceStudio/dss_home/code-envs/python/plugin_googlesheets_managed_1/include/site/python2.7/regex" failed with error code 1 in /private/var/folders/d5/z8d88qkx1tgg6p5hp_r71c2c0000gn/T/pip-install-e9IK9C/regex/
1,257 questions
1,286 answers
1,460 comments
11,809 users

┬ęDataiku 2012-2018 - Privacy Policy