0 votes

Hi there,

I am running Dataiku 5.1.0 and in the release notes of 5.1.0 it says:


  • It is now possible to use datasets in a Python or R recipe, even if they are not declared as inputs or outputs


Now I tried using this today on a Python 3.6 environment. In the Jupyter notebook, this seems to work just fine, but as soon as I saved it back to recipe and ran the recipte itself, it immediately gave me the error:

Job failed: Error in Python process: At line 21: <class 'Exception'>: Dataset jira_projects cannot be used : declare it as input or output of your recipe


Apparently it isn't functioning as expected.

reopened by

1 Answer

0 votes
Best answer

You need to add ignore_flow=True in the constructor of the Dataset() class
selected by
Thanks, this solved it.

Where could I have found this information?
You can find reference documentation on our Dataiku API Dataset class here: https://doc.dataiku.com/dss/latest/python-api/datasets.html#dataiku.Dataset
1,082 questions
1,126 answers
10,889 users

©Dataiku 2012-2018 - Privacy Policy