0 votes

I am trying to use DSS 5.0.2, free edition on my personal computer on OSX. I might have done something wrong, but the admin/admin login does not work anymore. I would like to reset this password. I have tried to follow these indications: https://doc.dataiku.com/dss/5.0//troubleshooting/problems/cannot-login.html

But on OSX, there is no ./bin/dsscli in the Dataiku folder ( /Applications/DataScienceStudio.app ) , and there is no bin folder at all when I search recursively. The dsscli folder is in  /Applications/DataScienceStudio.app/Contents/Resources/kit/python/dataiku/dsscli

I have tried to run `python -m dataiku.dsscli user-edit --password admin admin`, (after having set up an appropriate conda env to have the good version for each necessary package and solve the imports problems), but it still does not work, because of these 3 lines in /Applications/DataScienceStudio.app/Contents/Resources/kit/python/dataiku/dsscli/__main__.py :

key = get_or_create_api_key()   
port = int(os.environ["DKU_BACKEND_PORT"])
client = dataikuapi.DSSClient("" % port , key)

Is there an command equivalent to ./bin/dsscli user-edit --password NEW_PASSWORD LOGIN , but for OSX?

By the way: I am just trying to re-install DSS, there is nothing I want to keep in my current DSS. I have tried to delete the application folder, and every file with the name "dataiku" found on my computer, and then reinstall everything, but it does not reset the logins.
If you have a solution to totally uninstall DSS, remove the previous accounts, and reinstall it from scratch, it would be great.

1 Answer

0 votes


Sorry for the late reply. The dsscli on macOS is usually located here if you used the .dmg installer:


The dsscli file you have tried is from the installer, not the application. That is why I did not work.

You can use this command line interface as you tried: ./bin/dsscli user-edit --password NEW_PASSWORD LOGIN



1,218 questions
1,249 answers
11,782 users

©Dataiku 2012-2018 - Privacy Policy