0 votes

Strange things happens trying to upload simple excel file (.xlsx) to Dataiku from local computer. I will try to clearly explain how did I try to upload file and what went wrong:

  • I click "+Dataset" button and select "Upload your files".
  • Drag simple excel file with two columns.
  • In "Format/Preview" window I select "skip first lines" to 1 (to skip table names).
  • In "Schema" window I select new column name and formats I want. Table looks like as I expected in "Format/Preview" window.
  • Without any more changes in "Partitioning" and "Advanced" windows I press "CREATE".
  • Dataset that is created does not have columns that I specified (it has default columns col_0 and col_1 instead) and format of one of the columns is changed to boolean (Text is ecpected in both).

 I tried to redo the same procedure with .csv file and everything worked fine.

asked by

2 Answers

0 votes
Could you provide a sample of the Excel file?
answered by
I sent excel to you personal email (not sure if it's possible to upload file here...)
0 votes

Thanks, I tested it using the setting below:


 It is indeed a bug for Excel files when renaming the columns at the upload stage in the Settings menu. While we fix it, we recommend using a Prepare visual recipe to perform the renaming.

answered by
686 questions
705 answers
528 comments
434 users