0 votes
Hi Team,

It is been a week i have been trying to install DSS into my VMWARE image. I have tried RHEL, CentOS and Ubuntu. However i am facing packages and depandency problems.

When i issue dataiku-dss-4.1.0/installer.sh -d DATA_DIR -p 11000 in my Ubuntu wily version 15.10 Beta2.

I am getting below list of errors

 

[+] Creating data directory: DATA_DIR
[+] Saving installation log to /home/osboxes/DATA_DIR/run/install.log
[*] Could not find suitable version of Java
[+] Checking required dependencies
+ Detected OS distribution : ubuntu 15.10
+ Checking required packages...
*** Error: package git not found
*** Error: package nginx-full not found
*** Error: package default-jre-headless not found
*** Error: package libgfortran3 not found

[-] Dependency check failed
[-] You can install required dependencies with:
[-]    sudo -i "/home/osboxes/dataiku-dss-4.1.0/scripts/install/install-deps.sh"
[-] You can also disable this check with the -n installer flag

After this i have tried to install depandencies as mentioned above and i am getting,

 

[email protected]:~$  sudo -i "/home/osboxes/dataiku-dss-4.1.0/scripts/install/install-deps.sh"
[sudo] password for osboxes:
+ Detected OS distribution : ubuntu 15.10
+ Checking required repositories...
+ Installing required packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package git is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'git' has no installation candidate
E: Unable to locate package nginx-full
E: Unable to locate package default-jre-headless
E: Unable to locate package libgfortran3

Note : In the mean while i tried apt-get update then apt-get install git but same above problem.

Please help me to resolve the issue.

 

Regards,

Nantha.
asked by

2 Answers

0 votes
Hi,

Unfortunately, this means that your Ubuntu installation is partly broken, and you can't install Git on it. Note that apparently, you are using a non-release version of Ubuntu (Beta2), and of an Ubuntu version that is more than 2 years old.

You may try to run the DSS installer with the -n flag to skip dependencies check but it is possible that some parts will not work properly.
answered by
Hi Clement,
Thanks for your response. I dont know whether should i ask this question.

Would it be possible for you to provide the path to download iso image for right linux to get installed for DSS ? This would be great help.

The reason, i am interested in DSS and Datascience but unfortunately fed up of all these downloads and stuff. hence looking for guidance.

Would you ?
0 votes
I have downloaded Ubuntu 17.0 LTS desktop version and install the dependency. Now it is working fine.
answered by
710 questions
729 answers
559 comments
461 users