0 votes


I used to read this topic https://answers.dataiku.com/1054/how-do-i-install-the-ms-sql-server-driver-on-the-virtualbox-vm

But I still cannot do it. I really newbie in this area.

I try connect with and 22 it did not work for me.

By the way, the driver is a zip file (mysql-connector-java-5.1.27.zip) I cannot find JAR file inside there. How to get it?

Would you mind to explain more a bit or give me a link for beginner guide.


Thank you,

you have to send it via putty using a shh connection, there it will work. Have you tried it this way? if not I could explain you it took me like one whole week to be able to achive this task haha.
I try to connect with SSH....
then, what command I should do? (everything still default setting)

for now the command shows [[email protected] ~]$ _

Moreover, how to get JAR file from zip file?

1 Answer

0 votes
to get the jar file unzip it and open the folders until you get to one that is full of files (for me I had to open two folders using the default options to unzip "mysql-connector-java-5.1.43\mysql-connector-java-5.1.43")and there should be the jar file called "mysql-connector-java-5.1.43-bin.jar"

then, you use scp comand from the comand line example "scp -P (port) /file/to/send [email protected]:/where/to/put" for example I believe I used "scp -P 2222 C:/(..).jar [email protected]:/dss/lib/JDBC" or something along those lines.

also when you try to do the connection with the database administrator be sure to not put as the host, but the ip (i think is) that appears on top of the vm terminal when DSS is up
I try this command
"scp -P 2222 c:/mysql-connector-java-6.0.6/mysql-connector-java-6.0.6-bin.jar [email protected]:/dss/lib/JDBC"

It show
ssh: Could not resolve hostname c: Name or service not known

I am not sure, but it may mean it cannot find my pc?
(I use SSH command through google chrome)
Have you tried with "C" upper case, it might be because it is case sensitive.
I used to try, but it still same problem.

I am not sure but I try to connect dataiku before send the command
the command line is " [[email protected] ~]$ "
is it correct?
Oh, no, it should be the comand line of your host machine (which I guess is windows) where your file is.
Should be something like
ChangeLog/release notes: https://goo.gl/YnmXOs
Unable to parse destination: scp -P 2222 C:/mysql-connector-java-6.0.6/mysql-connector-java-6.0.6-bin.jar [email protected]:/dss/lib/JDBC
NaCl plugin exited with status code 1.
(R)econnect, (C)hoose another connection, or E(x)it?

but if I do not connect to the destination first where can I put the password?

[FYI] I use 'Secure Shell' in google Chrome
Okey, I am no expert with Secure shell, but I found this:
I hope this are useful,
For the question when you use scp and conects successfully, then you put the password to log into Dataiku's vm, after you introduce it correctly, then the file is copied.
I see. I may change the program for SSH and do this again.

I really thank you for  your help.

Thank you a lot, larispardo.
No problem, hope it helped in some fashion.
1,328 questions
1,350 answers
11,898 users

©Dataiku 2012-2018 - Privacy Policy