+2 votes

I am currently experiencing some issues with executions of recipes and datasets in dataiku.

The following error occurs when executing a python recipe:

"Failed to commit transaction, it has been rollbacked, caused by: FileNotFoundException: /home/dataiku/dss/config/.ts/projects--CLUSTERREPORTCLUSTERINGNEW--datasets--Companies_labelled_post_labelled.json (No space left on device)"

However, on my device there is plenty of space left.

Thanks for your help,


1 Answer

+1 vote
when you see a "No space left on device" in DSS or its logs, it's referring to the partition or disk or VM or docker volume where the config is stored (in your case /home/dataiku/dss/config). This is a low-level error and can only be solved by cleaning the corresponding partition or disk or ...

Note that this error usually "sticks", because when the program meets an error caused by no space left, some services will fail and shutdown, leaving DSS in an incoherent state. A restart of DSS will be needed.
A storage upgrade solved the issue.
Thank you.
What if this error occurs even though less than 60% of the disk is used? For example, "df -h" says only 38GB out of 64GB of disk space are used, still Dataiku stops working (only an error page with the message mentioned above is displayed).
1,322 questions
1,341 answers
11,889 users

©Dataiku 2012-2018 - Privacy Policy