0 votes
Hello guys,

I am setting up a connection to a PostgreSQL Instance, logged in as admin user (community edition).

It is possible for the admin user to create a new connection and fill out the required fields, however the two buttons "Test" and "Create" are greyed out. (Browser: Firefox Portable)

From my understanding, only the administrator has the privilege to create such a connection.

 

What am I missing here? Is there another "administrator" user?

 

Thanks in advance.
asked by

1 Answer

0 votes
It should not be a permission issue. The chief reason for these buttons to be disabled would be a required field not being filled: notably, make sure that you filled the "New connection name" field.
answered by
Is there another required field other than "New connection name"?
Obviously the connection parameters are required, but it seems that the connection name itself should be enough to at least save a new connection?

It is weird that the "Test" button is also disabled, so I cant get any feedback whats wrong.
For PostgreSQL, the required fields are: connection name,  host, database, user. As soon as these 4 fields are filled, the Test and Create button should ungrey

HOWEVER: there is a bug if you enable the "advanced URL syntax mode". In that case, you still need to fill host, database and user (though they will not be used, you need to fill "dummy" stuff.
Thanks!

The bug was the problem, I was trying to setup via advanced URL syntax.
944 questions
978 answers
996 comments
2,162 users

©Dataiku 2012-2018 - Privacy Policy